What’s Vulnerable › Vulnerabilities
CVE-2024-2844: Easy Appointments <= 3.11.18 - Insufficient Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-862
Description
The Easy Appointments plugin for WordPress is vulnerable to unauthorized modification of data due to insufficient user validation on the ajax_cancel_appointment() function in all versions up to, and including, 3.11.18. This makes it possible for unauthenticated attackers to cancel other users orders.
Affected products
- Easy Appointments: before 3.11.19 — fixed in 3.11.19
How to fix
Upgrade to a fixed version: Easy Appointments 3.11.19. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/easy-appointments/trunk/src/ajax.php#L380
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3059359%40easy-appointments&new=3059359%40easy-appointments&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c0d8ac01-ac73-47ea-839b-edc820436f27?source=cve
- https://plugins.trac.wordpress.org/browser/easy-appointments/trunk/src/ajax.php#L380
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3059359%40easy-appointments&new=3059359%40easy-appointments&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c0d8ac01-ac73-47ea-839b-edc820436f27?source=cve
Get alerted when CVE-2024-2844 or the next vulnerability affects your stack