What’s Vulnerable › Vulnerabilities
CVE-2024-2868: ShopLentor – WooCommerce Builder for Elementor & Gutenberg +12 Modules – All in One Solution (formerly WooLentor) <= 2.8.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via WL Universal Product Layout
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The ShopLentor – WooCommerce Builder for Elementor & Gutenberg +12 Modules – All in One Solution (formerly WooLentor) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the slitems parameter in the WL Special Day Offer Widget in all versions up to, and including, 2.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access or above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin 2.8.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/2.8.2/includes/addons/universal_product.php#L2548
- https://plugins.trac.wordpress.org/changeset/3061864/woolentor-addons/tags/2.8.4/includes/addons/universal_product.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/27b8e0c0-fb0b-4d36-abc4-3e66ec7b5195?source=cve
- https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/2.8.2/includes/addons/universal_product.php#L2548
- https://plugins.trac.wordpress.org/changeset/3061864/woolentor-addons/tags/2.8.4/includes/addons/universal_product.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/27b8e0c0-fb0b-4d36-abc4-3e66ec7b5195?source=cve
Get alerted when CVE-2024-2868 or the next vulnerability affects your stack