What’s Vulnerable › Vulnerabilities
CVE-2024-2869: Easy Property Listings <= 3.5.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Property Listings WordPress plugin before 3.5.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Easy Property Listings: before 3.5.4 — fixed in 3.5.4
How to fix
Upgrade to a fixed version: Easy Property Listings 3.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4093c12e-f62b-4357-8893-649cd2aaeace/
- https://wpscan.com/vulnerability/4093c12e-f62b-4357-8893-649cd2aaeace/
Get alerted when CVE-2024-2869 or the next vulnerability affects your stack