What’s Vulnerable › Vulnerabilities
CVE-2024-2870: Swift Framework < 2024.04.30 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The socialdriver-framework WordPress plugin before 2024.04.30 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- socialdriver-framework: before 2024.04.30 — fixed in 2024.04.30
How to fix
Upgrade to a fixed version: socialdriver-framework 2024.04.30. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/688522d2-ee28-44f8-828d-352f06e43885/
- https://wpscan.com/vulnerability/688522d2-ee28-44f8-828d-352f06e43885/
Get alerted when CVE-2024-2870 or the next vulnerability affects your stack