What’s Vulnerable › Vulnerabilities
CVE-2024-2872: Swift Framework < 2024.04.30 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The socialdriver-framework WordPress plugin before 2024.04.30 does not sanitise and escape some of its settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- socialdriver-framework: before 2024.04.30 — fixed in 2024.04.30
How to fix
Upgrade to a fixed version: socialdriver-framework 2024.04.30. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-2872 or the next vulnerability affects your stack