What’s Vulnerable › Vulnerabilities
CVE-2024-2873: User authentication bypass in wolfSSH server
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-25 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability was found in wolfSSH's server-side state machine before versions 1.4.17. A malicious client could create channels without first performing user authentication, resulting in unauthorized access.
Affected products
- wolfSSL Inc. wolfSSH: before 1.4.17 — fixed in 1.4.17
How to fix
Upgrade to a fixed version: wolfSSL Inc. wolfSSH 1.4.17. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssh/pull/670
- https://github.com/wolfSSL/wolfssh/pull/671
- https://www.wolfssl.com/docs/security-vulnerabilities/
- https://github.com/wolfSSL/wolfssh/pull/670
- https://github.com/wolfSSL/wolfssh/pull/671
- https://www.wolfssl.com/docs/security-vulnerabilities/
Get alerted when CVE-2024-2873 or the next vulnerability affects your stack