What’s Vulnerable › Vulnerabilities

CVE-2024-28746: Apache Airflow: Ignored Airflow Permissions

Description

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Affected products

How to fix

Upgrade to a fixed version: Apache Airflow 2.8.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-28746 or the next vulnerability affects your stack