What’s Vulnerable › Vulnerabilities

CVE-2024-28776: IBM Cognos Controller cross-site scripting

Description

IBM Cognos Controller 11.0.0 through 11.0.1 FP3 and IBM Controller 11.1.0 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

Affected products

How to fix

Upgrade to a fixed version: IBM Cognos Controller 11.0.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-28776 or the next vulnerability affects your stack