What’s Vulnerable › Vulnerabilities
CVE-2024-28781: IBM UrbanCode Deploy cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM UrbanCode Deploy (UCD) 7.0 through 7.0.5.20, 7.1 through 7.1.2.16, 7.2 through 7.2.3.9, 7.3 through 7.3.2.4, and 8.0 through 8.0.0.1 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 285654.
Affected products
- IBM DevOps Deploy: from 8.0.0.0 before 8.0.1.0 — fixed in 8.0.1.0
- IBM UrbanCode Deploy: from 7.0.0.0 before 7.0.5.21; from 7.1.0.0 before 7.1.2.17; from 7.2.0.0 before 7.2.3.10; from 7.3.0.0 before 7.3.2.5 — fixed in 7.0.5.21, 7.1.2.17, 7.2.3.10, 7.3.2.5
How to fix
Upgrade to a fixed version: IBM DevOps Deploy 8.0.1.0; IBM UrbanCode Deploy 7.0.5.21, 7.1.2.17, 7.2.3.10, 7.3.2.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/285654
- https://www.ibm.com/support/pages/node/7150747
- https://exchange.xforce.ibmcloud.com/vulnerabilities/285654
- https://www.ibm.com/support/pages/node/7150747
Get alerted when CVE-2024-28781 or the next vulnerability affects your stack