What’s Vulnerable › Vulnerabilities
CVE-2024-28849: Proxy-Authorization header kept across hosts in follow-redirects
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-14 · updated 2026-06-17
- Weakness: CWE-200
Description
follow-redirects is an open source, drop-in replacement for Node's `http` and `https` modules that automatically follows redirects. In affected versions follow-redirects only clears authorization header during cross-domain redirect, but keep the proxy-authentication header which contains credentials too. This vulnerability may lead to credentials leak, but has been addressed in version 1.15.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- follow-redirects: before 1.15.6 — fixed in 1.15.6
- Npm Follow-Redirects: before 1.15.6 — fixed in 1.15.6
How to fix
Upgrade to a fixed version: follow-redirects 1.15.6; Npm Follow-Redirects 1.15.6. Check the vendor advisory for mitigations.
References
- https://fetch.spec.whatwg.org/#authentication-entries
- https://github.com/follow-redirects/follow-redirects/commit/c4f847f85176991f95ab9c88af63b1294de8649b
- https://github.com/follow-redirects/follow-redirects/security/advisories/GHSA-cxjh-pqwp-8mfp
- https://github.com/psf/requests/issues/1885
- https://hackerone.com/reports/2390009
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VOIF4EPQUCKDBEVTGRQDZ3CGTYQHPO7Z/
- https://fetch.spec.whatwg.org/#authentication-entries
- https://github.com/follow-redirects/follow-redirects/commit/c4f847f85176991f95ab9c88af63b1294de8649b
- https://github.com/follow-redirects/follow-redirects/security/advisories/GHSA-cxjh-pqwp-8mfp
- https://github.com/psf/requests/issues/1885
- https://hackerone.com/reports/2390009
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VOIF4EPQUCKDBEVTGRQDZ3CGTYQHPO7Z/
Get alerted when CVE-2024-28849 or the next vulnerability affects your stack