What’s Vulnerable › Vulnerabilities
CVE-2024-28852: Ampache has multiple reflective XSS vulnerabilities
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Ampache is a web based audio/video streaming application and file manager. Ampache has multiple reflective XSS vulnerabilities,this means that all forms in the Ampache that use `rule` as a variable are not secure. For example, when querying a song, when querying a podcast, we need to use `$rule` variable. This vulnerability is fixed in 6.3.1
Affected products
- ampache: before 6.3.1 — fixed in 6.3.1
How to fix
Upgrade to a fixed version: ampache 6.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/ampache/ampache/blob/bcaa9a4624acf8c8cc4c135be77b846731fb1ba2/src/Repository/Model/Search.php#L1732-L1740
- https://github.com/ampache/ampache/security/advisories/GHSA-g7hx-hm68-f639
- https://github.com/ampache/ampache/blob/bcaa9a4624acf8c8cc4c135be77b846731fb1ba2/src/Repository/Model/Search.php#L1732-L1740
- https://github.com/ampache/ampache/security/advisories/GHSA-g7hx-hm68-f639
Get alerted when CVE-2024-28852 or the next vulnerability affects your stack