What’s Vulnerable › Vulnerabilities
CVE-2024-28853: Ampache Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Ampache is a web based audio/video streaming application and file manager. Stored Cross Site Scripting (XSS) vulnerability in ampache before v6.3.1 allows a remote attacker to execute code via a crafted payload to serval parameters in the post request of /preferences.php?action=admin_update_preferences. This vulnerability is fixed in 6.3.1.
Affected products
- ampache: before 6.3.1 — fixed in 6.3.1
How to fix
Upgrade to a fixed version: ampache 6.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/ampache/ampache/security/advisories/GHSA-prw2-7cr3-5mx8
- https://github.com/ampache/ampache/security/advisories/GHSA-prw2-7cr3-5mx8
Get alerted when CVE-2024-28853 or the next vulnerability affects your stack