What’s Vulnerable › Vulnerabilities
CVE-2024-28854: Slow loris vulnerability with default configuration in tls-listener
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-400
Description
tls-listener is a rust lang wrapper around a connection listener to support TLS. With the default configuration of tls-listener, a malicious user can open 6.4 `TcpStream`s a second, sending 0 bytes, and can trigger a DoS. The default configuration options make any public service using `TlsListener::new()` vulnerable to a slow-loris DoS attack. This impacts any publicly accessible service using the default configuration of tls-listener in versions prior to 0.10.0. Users are advised to upgrade. Users unable to upgrade may mitigate this by passing a large value, such as `usize::MAX` as the parameter to `Builder::max_handshakes`.
Affected products
- tmccombs tls-listener: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: tmccombs tls-listener 0.10.0. Check the vendor advisory for mitigations.
References
- https://en.wikipedia.org/wiki/Slowloris_(computer_security)
- https://github.com/tmccombs/tls-listener/commit/d5a7655d6ea9e53ab57c3013092c5576da964bc4
- https://github.com/tmccombs/tls-listener/security/advisories/GHSA-2qph-qpvm-2qf7
- https://en.wikipedia.org/wiki/Slowloris_(computer_security)
- https://github.com/tmccombs/tls-listener/commit/d5a7655d6ea9e53ab57c3013092c5576da964bc4
- https://github.com/tmccombs/tls-listener/security/advisories/GHSA-2qph-qpvm-2qf7
Get alerted when CVE-2024-28854 or the next vulnerability affects your stack