What’s Vulnerable › Vulnerabilities
CVE-2024-28860: Insecure IPsec transport encryption in Cilium
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-326
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Users of IPsec transparent encryption in Cilium may be vulnerable to cryptographic attacks that render the transparent encryption ineffective. In particular, Cilium is vulnerable to chosen plaintext, key recovery, replay attacks by a man-in-the-middle attacker. These attacks are possible due to an ESP sequence number collision when multiple nodes are configured with the same key. Fixed versions of Cilium use unique keys for each IPsec tunnel established between nodes, resolving all of the above attacks. This vulnerability is fixed in 1.13.13, 1.14.9, and 1.15.3.
Affected products
- cilium: from 1.4.0 before 1.13.14; from 1.14.0 before 1.14.9; from 1.15.0 before 1.15.3 — fixed in 1.13.14, 1.14.9, 1.15.3
How to fix
Upgrade to a fixed version: cilium 1.13.14, 1.14.9, 1.15.3. Check the vendor advisory for mitigations.
References
- https://docs.cilium.io/en/stable/security/network/encryption-ipsec
- https://github.com/cilium/cilium/commit/311fbce5280491cddceab178d83b06fa23688c72
- https://github.com/cilium/cilium/commit/a1742b478306fa256cd27df1039dfae0537b4149
- https://github.com/cilium/cilium/commit/a652c123331852cca90c74202f993d4170fd37fa
- https://github.com/cilium/cilium/security/advisories/GHSA-pwqm-x5x6-5586
- https://docs.cilium.io/en/stable/security/network/encryption-ipsec
- https://github.com/cilium/cilium/commit/311fbce5280491cddceab178d83b06fa23688c72
- https://github.com/cilium/cilium/commit/a1742b478306fa256cd27df1039dfae0537b4149
- https://github.com/cilium/cilium/commit/a652c123331852cca90c74202f993d4170fd37fa
- https://github.com/cilium/cilium/security/advisories/GHSA-pwqm-x5x6-5586
Get alerted when CVE-2024-28860 or the next vulnerability affects your stack