What’s Vulnerable › Vulnerabilities
CVE-2024-28861: Gadget chain in Symfony 1 due to uncontrolled unserialized input in sfNamespacedParameterHolder
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-22 · updated 2026-06-17
- Weakness: CWE-502
Description
Symfony 1 is a community-driven fork of the 1.x branch of Symfony, a PHP framework for web projects. Starting in version 1.1.0 and prior to version 1.5.19, Symfony 1 has a gadget chain due to dangerous deserialization in `sfNamespacedParameterHolder` class that would enable an attacker to get remote code execution if a developer deserializes user input in their project. Version 1.5.19 contains a patch for the issue.
Affected products
- FriendsOfSymfony1 symfony1: from 1.1.0 before 1.5.9 — fixed in 1.5.9
How to fix
Upgrade to a fixed version: FriendsOfSymfony1 symfony1 1.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfSymfony1/symfony1/commit/0bd9d59c69221f49bfc8be8b871b79e12d7d171a
- https://github.com/FriendsOfSymfony1/symfony1/security/advisories/GHSA-pv9j-c53q-h433
- https://github.com/FriendsOfSymfony1/symfony1/commit/0bd9d59c69221f49bfc8be8b871b79e12d7d171a
- https://github.com/FriendsOfSymfony1/symfony1/security/advisories/GHSA-pv9j-c53q-h433
Get alerted when CVE-2024-28861 or the next vulnerability affects your stack