What’s Vulnerable › Vulnerabilities
CVE-2024-28862: ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-16 · updated 2026-06-17
- Weakness: CWE-276
Description
The Ruby One Time Password library (ROTP) is an open source library for generating and validating one time passwords. Affected versions had overly permissive default permissions. Users should patch to version 6.3.0. Users unable to patch may correct file permissions after installation.
Affected products
- mdp rotp: from 6.2.1 before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: mdp rotp 6.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/mdp/rotp/security/advisories/GHSA-x2h8-qmj4-g62f
- https://github.com/mdp/rotp/security/advisories/GHSA-x2h8-qmj4-g62f
Get alerted when CVE-2024-28862 or the next vulnerability affects your stack