What’s Vulnerable › Vulnerabilities
CVE-2024-28872: Incorrect TLS certificate validation can lead to escalated privileges
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-295
Description
The TLS certificate validation code is flawed. An attacker can obtain a TLS certificate from the Stork server and use it to connect to the Stork agent. Once this connection is established with the valid certificate, the attacker can send malicious commands to a monitored service (Kea or BIND 9), possibly resulting in confidential data loss and/or denial of service. It should be noted that this vulnerability is not related to BIND 9 or Kea directly, and only customers using the Stork management tool are potentially affected. This issue affects Stork versions 0.15.0 through 1.15.0.
Affected products
- ISC Stork: from 0.15.0 before 1.15.1 — fixed in 1.15.1
How to fix
Upgrade to a fixed version: ISC Stork 1.15.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-28872 or the next vulnerability affects your stack