What’s Vulnerable › Vulnerabilities
CVE-2024-28877: MicroDicom DICOM Viewer Stack-based Buffer Overflow
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-11 · updated 2026-06-17
- Weakness: CWE-121
Description
MicroDicom DICOM Viewer is vulnerable to a stack-based buffer overflow, which may allow an attacker to execute arbitrary code on affected installations of DICOM Viewer. User interaction is required to exploit this vulnerability.
Affected products
- MicroDicom DICOM Viewer: before 2024.2 — fixed in 2024.2
How to fix
Upgrade to a fixed version: MicroDicom DICOM Viewer 2024.2. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-24-163-01
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-24-163-01
Get alerted when CVE-2024-28877 or the next vulnerability affects your stack