What’s Vulnerable › Vulnerabilities
CVE-2024-28882
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-772
Description
OpenVPN from 2.6.0 through 2.6.10 in a server role accepts multiple exit notifications from authenticated clients which will extend the validity of a closing session
Affected products
- OpenVPN: from 2.6.0 before 2.6.11 — fixed in 2.6.11
How to fix
Upgrade to a fixed version: OpenVPN 2.6.11. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2024-28882
- https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07634.html
- https://community.openvpn.net/openvpn/wiki/CVE-2024-28882
- https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07634.html
Get alerted when CVE-2024-28882 or the next vulnerability affects your stack