What’s Vulnerable › Vulnerabilities
CVE-2024-28948: Advantech ADAM-5630 Cross-Site Request Forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-352
Description
Advantech ADAM-5630 contains a cross-site request forgery (CSRF) vulnerability. It allows an attacker to partly circumvent the same origin policy, which is designed to prevent different websites from interfering with each other.
Affected products
- Advantech ADAM-5630: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: Advantech ADAM-5630 2.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-28948 or the next vulnerability affects your stack