What’s Vulnerable › Vulnerabilities

CVE-2024-28949: DoS via a large number of User Preferences

Description

Mattermost Server versions 9.5.x before 9.5.2, 9.4.x before 9.4.4, 9.3.x before 9.3.3, 8.1.x before 8.1.11 don't limit the number of user preferences which allows an attacker to send a large number of user preferences potentially causing denial of service.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.11, 9.3.3, 9.4.4, 9.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-28949 or the next vulnerability affects your stack