What’s Vulnerable › Vulnerabilities
CVE-2024-28981: Hitachi Vantara Pentaho Data Integration & Analytics - Insufficiently Protected Credentials
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-522
Description
Hitachi Vantara Pentaho Data Integration & Analytics versions before 10.1.0.0 and 9.3.0.8, including 8.3.x, discloses database passwords when searching metadata injectable fields.
Affected products
- Hitachi Vantara Pentaho Data Integration & Analytics: from 1.0 before 9.3.0.8; from 9.4.0.0 before 10.1.0.0 — fixed in 10.1.0.0, 9.3.0.8
How to fix
Upgrade to a fixed version: Hitachi Vantara Pentaho Data Integration & Analytics 10.1.0.0, 9.3.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-28981 or the next vulnerability affects your stack