What’s Vulnerable › Vulnerabilities
CVE-2024-29003: SolarWinds Platform Cross Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The SolarWinds Platform was susceptible to a XSS vulnerability that affects the maps section of the user interface. This vulnerability requires authentication and requires user interaction.
Affected products
- SolarWinds Platform: before 2024.1.1 — fixed in 2024.1.1
How to fix
Upgrade to a fixed version: SolarWinds Platform 2024.1.1. Check the vendor advisory for mitigations.
References
- https://documentation.solarwinds.com/en/success_center/orionplatform/content/release_notes/solarwinds_platform_2024-1-1_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2024-29003
- https://documentation.solarwinds.com/en/success_center/orionplatform/content/release_notes/solarwinds_platform_2024-1-1_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2024-29003
Get alerted when CVE-2024-29003 or the next vulnerability affects your stack