What’s Vulnerable › Vulnerabilities
CVE-2024-29008: Apache CloudStack: The extraconfig feature can be abused to load hypervisor resources on a VM instance
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-04 · updated 2026-06-17
- Weakness: CWE-20
Description
A problem has been identified in the CloudStack additional VM configuration (extraconfig) feature which can be misused by anyone who has privilege to deploy a VM instance or configure settings of an already deployed VM instance, to configure additional VM configuration even when the feature is not explicitly enabled by the administrator. In a KVM based CloudStack environment, an attacker can exploit this issue to attach host devices such as storage disks, and PCI and USB devices such as network adapters and GPUs, in a regular VM instance that can be further exploited to gain access to the underlying network and storage infrastructure resources, and access any VM instance disks on the local storage. Users are advised to upgrade to version 4.18.1.1 or 4.19.0.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.14.0.0 before 4.18.1.1; 4.19.0.0 — fixed in 4.18.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.18.1.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/82f46pv7mvh95ybto5hn8wlo6g8jhjvp
- https://lists.apache.org/thread/82f46pv7mvh95ybto5hn8wlo6g8jhjvp
Get alerted when CVE-2024-29008 or the next vulnerability affects your stack