What’s Vulnerable › Vulnerabilities
CVE-2024-29020: JumpServer allows nn authorized attacker to get sensitive information in playbook files when playbook_id is leaked
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-639
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. An authorized attacker can obtain sensitive information contained within playbook files if they manage to learn the playbook_id of another user. This breach of confidentiality can lead to information disclosure and exposing sensitive data. This vulnerability is fixed in v3.10.6.
Affected products
- jumpserver: from 3.0.0 before 3.10.6 — fixed in 3.10.6
How to fix
Upgrade to a fixed version: jumpserver 3.10.6. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7mqc-23hr-cr62
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7mqc-23hr-cr62
Get alerted when CVE-2024-29020 or the next vulnerability affects your stack