What’s Vulnerable › Vulnerabilities
CVE-2024-29025: Netty HttpPostRequestDecoder can OOM
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-25 · updated 2026-06-17
- Weakness: CWE-770
Description
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `HttpPostRequestDecoder` can be tricked to accumulate data. While the decoder can store items on the disk if configured so, there are no limits to the number of fields the form can have, an attacher can send a chunked post consisting of many small fields that will be accumulated in the `bodyListHttpData` list. The decoder cumulates bytes in the `undecodedChunk` buffer until it can decode a field, this field can cumulate data without limits. This vulnerability is fixed in 4.1.108.Final.
Affected products
- Debian Linux: 10.0
- netty: before 4.1.108 — fixed in 4.1.108
How to fix
Upgrade to a fixed version: netty 4.1.108. Check the vendor advisory for mitigations.
References
- https://gist.github.com/vietj/f558b8ea81ec6505f1e9a6ca283c9ae3
- https://github.com/netty/netty/commit/0d0c6ed782d13d423586ad0c71737b2c7d02058c
- https://github.com/netty/netty/security/advisories/GHSA-5jpm-x58v-624v
- https://lists.debian.org/debian-lts-announce/2024/06/msg00015.html
- https://gist.github.com/vietj/f558b8ea81ec6505f1e9a6ca283c9ae3
- https://github.com/netty/netty/commit/0d0c6ed782d13d423586ad0c71737b2c7d02058c
- https://github.com/netty/netty/security/advisories/GHSA-5jpm-x58v-624v
- https://lists.debian.org/debian-lts-announce/2024/06/msg00015.html
Get alerted when CVE-2024-29025 or the next vulnerability affects your stack