What’s Vulnerable › Vulnerabilities
CVE-2024-29028: memos vulnerable to an SSRF in /o/get/httpmeta
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-19 · updated 2026-06-17
- Weakness: CWE-918
Description
memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /o/get/httpmeta that allows unauthenticated users to enumerate the internal network and receive limited html values in json form. This vulnerability is fixed in 0.16.1.
Affected products
- usememos/memos: from 0.13.2 before 0.16.1 — fixed in 0.16.1
How to fix
Upgrade to a fixed version: usememos/memos 0.16.1. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/6ffc09d86a1302c384ef085aa70c7bddb3ce7ba9
- https://securitylab.github.com/advisories/GHSL-2023-154_GHSL-2023-156_memos
- https://github.com/usememos/memos/commit/6ffc09d86a1302c384ef085aa70c7bddb3ce7ba9
- https://securitylab.github.com/advisories/GHSL-2023-154_GHSL-2023-156_memos
Get alerted when CVE-2024-29028 or the next vulnerability affects your stack