What’s Vulnerable › Vulnerabilities
CVE-2024-29030: memos vulnerable to an SSRF in /api/resource
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-19 · updated 2026-06-17
- Weakness: CWE-918
Description
memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /api/resource that allows authenticated users to enumerate the internal network. Version 0.22.0 of memos removes the vulnerable file.
Affected products
- usememos/memos: from 0.13.2 before 0.22.0 — fixed in 0.22.0
How to fix
Upgrade to a fixed version: usememos/memos 0.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/blob/06dbd8731161245444f4b50f4f9ed267f7c3cf63/api/v1/resource.go#L83
- https://github.com/usememos/memos/commit/bbd206e8930281eb040cc8c549641455892b9eb5
- https://securitylab.github.com/advisories/GHSL-2023-154_GHSL-2023-156_memos/
- https://github.com/usememos/memos/blob/06dbd8731161245444f4b50f4f9ed267f7c3cf63/api/v1/resource.go#L83
- https://github.com/usememos/memos/commit/bbd206e8930281eb040cc8c549641455892b9eb5
- https://securitylab.github.com/advisories/GHSL-2023-154_GHSL-2023-156_memos/
Get alerted when CVE-2024-29030 or the next vulnerability affects your stack