What’s Vulnerable › Vulnerabilities
CVE-2024-2907: AGCA – Custom Dashboard & Login Page < 7.2.2 - Admin+ Stored XSS via Image URL
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The AGCA WordPress plugin before 7.2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Cusmin Absolutely Glamorous Custom Admin: before 7.2.2 — fixed in 7.2.2
How to fix
Upgrade to a fixed version: Cusmin Absolutely Glamorous Custom Admin 7.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d2588b47-a518-4cb2-a557-2c7eaffa17e4/
- https://wpscan.com/vulnerability/d2588b47-a518-4cb2-a557-2c7eaffa17e4/
Get alerted when CVE-2024-2907 or the next vulnerability affects your stack