What’s Vulnerable › Vulnerabilities
CVE-2024-2908: Call Now Button < 1.4.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Call Now Button WordPress plugin before 1.4.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Call Now Button: before 1.4.7 — fixed in 1.4.7
How to fix
Upgrade to a fixed version: Call Now Button 1.4.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/58c9e088-ed74-461a-b305-e217679f26c1/
- https://wpscan.com/vulnerability/58c9e088-ed74-461a-b305-e217679f26c1/
Get alerted when CVE-2024-2908 or the next vulnerability affects your stack