What’s Vulnerable › Vulnerabilities
CVE-2024-29100: WordPress AI Engine plugin <= 2.1.4 - Arbitrary File Upload vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-434
Description
Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 2.1.4.
Affected products
- AI Engine: before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: AI Engine 2.1.5. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/ai-engine/wordpress-ai-engine-plugin-2-1-4-arbitrary-file-upload-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/ai-engine/wordpress-ai-engine-plugin-2-1-4-arbitrary-file-upload-vulnerability?_s_id=cve
Get alerted when CVE-2024-29100 or the next vulnerability affects your stack