What’s Vulnerable › Vulnerabilities
CVE-2024-29107: WordPress Elementor Addon Elements plugin <= 1.12.10 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPVibes Elementor Addon Elements allows Stored XSS.This issue affects Elementor Addon Elements: from n/a through 1.12.10.
Affected products
- wpvibes Addon Elements for Elementor (formerly Elementor Addon Elements): before 1.12.11 — fixed in 1.12.11
How to fix
Upgrade to a fixed version: wpvibes Addon Elements for Elementor (formerly Elementor Addon Elements) 1.12.11. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/addon-elements-for-elementor-page-builder/wordpress-elementor-addon-elements-plugin-1-12-10-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/addon-elements-for-elementor-page-builder/wordpress-elementor-addon-elements-plugin-1-12-10-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29107 or the next vulnerability affects your stack