What’s Vulnerable › Vulnerabilities
CVE-2024-29109: WordPress Shariff Wrapper plugin <= 4.6.10 - Contributor+ Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jan-Peter Lambeck & 3UU Shariff Wrapper allows Stored XSS.This issue affects Shariff Wrapper: from n/a through 4.6.10.
Affected products
- 3uu Shariff Wrapper: before 4.6.11 — fixed in 4.6.11
How to fix
Upgrade to a fixed version: 3uu Shariff Wrapper 4.6.11. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/shariff/wordpress-shariff-wrapper-plugin-4-6-10-contributor-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/shariff/wordpress-shariff-wrapper-plugin-4-6-10-contributor-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29109 or the next vulnerability affects your stack