What’s Vulnerable › Vulnerabilities
CVE-2024-29112: WordPress WooCommerce Google Feed Manager plugin <= 2.2.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Marketing Robot WooCommerce Google Feed Manager allows Stored XSS.This issue affects WooCommerce Google Feed Manager: from n/a through 2.2.0.
Affected products
- aukejomm WPMR Google Feed Manager for WooCommerce – Sell on Google Merchant Center & Shopping: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: aukejomm WPMR Google Feed Manager for WooCommerce – Sell on Google Merchant Center & Shopping 2.3.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-product-feed-manager/wordpress-woocommerce-google-feed-manager-plugin-2-2-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-product-feed-manager/wordpress-woocommerce-google-feed-manager-plugin-2-2-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29112 or the next vulnerability affects your stack