What’s Vulnerable › Vulnerabilities
CVE-2024-29131: Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons Configuration: from 2.0 before 2.10.1 — fixed in 2.10.1
- Fedoraproject Fedora: 39, 40
- NetApp Ontap Tools: 10
- NetApp SnapCenter: all versions
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Configuration 2.10.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/20/4
- https://lists.apache.org/thread/03nzzzjn4oknyw5y0871tw7ltj0t3r37
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS/
- http://www.openwall.com/lists/oss-security/2024/03/20/4
- https://lists.apache.org/thread/03nzzzjn4oknyw5y0871tw7ltj0t3r37
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS/
- https://security.netapp.com/advisory/ntap-20241213-0001/
Get alerted when CVE-2024-29131 or the next vulnerability affects your stack