What’s Vulnerable › Vulnerabilities
CVE-2024-29133: Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-21 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons Configuration: from 2.0 before 2.10.1 — fixed in 2.10.1
- Fedoraproject Fedora: 39, 40
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Configuration 2.10.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/20/3
- https://lists.apache.org/thread/ccb9w15bscznh6tnp3wsvrrj9crbszh2
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS/
- http://www.openwall.com/lists/oss-security/2024/03/20/3
- https://lists.apache.org/thread/ccb9w15bscznh6tnp3wsvrrj9crbszh2
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SNKDKEEKZNL5FGCTZKJ6CFXFVWFL5FJ7/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YD4AFTIIQW662LUAQRMWS6BBKYSZG3YS/
Get alerted when CVE-2024-29133 or the next vulnerability affects your stack