What’s Vulnerable › Vulnerabilities
CVE-2024-29142: WordPress Better Search plugin <= 3.3.0 - Stored Cross Site Scripting (XSS) vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WebberZone Better Search – Relevant search results for WordPress allows Stored XSS.This issue affects Better Search – Relevant search results for WordPress: from n/a through 3.3.0.
Affected products
- Ajay Better Search: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: Ajay Better Search 3.3.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/better-search/wordpress-better-search-plugin-3-3-0-stored-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/better-search/wordpress-better-search-plugin-3-3-0-stored-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-29142 or the next vulnerability affects your stack