What’s Vulnerable › Vulnerabilities
CVE-2024-29164
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-121
Description
HDF5 through 1.14.3 contains a stack buffer overflow in H5R__decode_heap, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.
Affected products
- HDF5: before 1.14.4 — fixed in 1.14.4
How to fix
Upgrade to a fixed version: HDF5 1.14.4. Check the vendor advisory for mitigations.
References
- https://www.hdfgroup.org/2024/05/new-hdf5-cve-issues-fixed-in-1-14-4/
- https://www.hdfgroup.org/2024/05/new-hdf5-cve-issues-fixed-in-1-14-4/
Get alerted when CVE-2024-29164 or the next vulnerability affects your stack