What’s Vulnerable › Vulnerabilities
CVE-2024-29169
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-89
Description
Dell SCG, versions prior to 5.22.00.00, contain a SQL Injection Vulnerability in the SCG UI for an internal audit REST API. A remote authenticated attacker could potentially exploit this vulnerability, leading to the execution of certain SQL commands on the application's backend database causing potential unauthorized access and modification of application data.
Affected products
- Dell Secure Connect Gateway (SCG) 5.0 Appliance - SRS: from 5.18.00.20 before 5.24.00.14 — fixed in 5.24.00.14
How to fix
Upgrade to a fixed version: Dell Secure Connect Gateway (SCG) 5.0 Appliance - SRS 5.24.00.14. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000225910/dsa-2024-181-security-update-for-dell-secure-connect-gateway-application-and-appliance-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000225910/dsa-2024-181-security-update-for-dell-secure-connect-gateway-application-and-appliance-vulnerabilities
Get alerted when CVE-2024-29169 or the next vulnerability affects your stack