What’s Vulnerable › Vulnerabilities
CVE-2024-29176
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Dell PowerProtect DD, version(s) 8.0, 7.13.1.0, 7.10.1.30, 7.7.5.40, contain(s) an Out-of-bounds Write vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Code execution.
Affected products
- Dell PowerProtect Data Domain: from 7.0 before 7.7.5.40; from 7.8.0.0 before 7.10.1.30; from 7.11.0.0 before 7.13.1.0; before 5.16.0.0 — fixed in 5.16.0.0, 7.10.1.30, 7.13.1.0, 7.7.5.40
How to fix
Upgrade to a fixed version: Dell PowerProtect Data Domain 5.16.0.0, 7.10.1.30, 7.13.1.0, 7.7.5.40. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000226148/dsa-2024-219-dell-technologies-powerprotect-dd-security-update-for-multiple-security-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000226148/dsa-2024-219-dell-technologies-powerprotect-dd-security-update-for-multiple-security-vulnerabilities
Get alerted when CVE-2024-29176 or the next vulnerability affects your stack