What’s Vulnerable › Vulnerabilities
CVE-2024-29185: FreeScout OS Command Injection vulnerability
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-22 · updated 2026-06-17
- Weakness: CWE-78
Description
FreeScout is a self-hosted help desk and shared mailbox. Versions prior to 1.8.128 are vulnerable to OS Command Injection in the /public/tools.php source file. The value of the php_path parameter is being executed as an OS command by the shell_exec function, without validating it. This allows an adversary to execute malicious OS commands on the server. A practical demonstration of the successful command injection attack extracted the /etc/passwd file of the server. This represented the complete compromise of the server hosting the FreeScout application. This attack requires an attacker to know the `App_Key` of the application. This limitation makes the Attack Complexity to be High. If an attacker gets hold of the `App_Key`, the attacker can compromise the Complete server on which the application is deployed. Version 1.8.128 contains a patch for this issue.
Affected products
- freescout-help-desk freescout: before 1.8.128 — fixed in 1.8.128
How to fix
Upgrade to a fixed version: freescout-help-desk freescout 1.8.128. Check the vendor advisory for mitigations.
References
- https://github.com/freescout-helpdesk/freescout/security/advisories/GHSA-7p9x-ch4c-vqj9
- https://github.com/freescout-helpdesk/freescout/security/advisories/GHSA-7p9x-ch4c-vqj9
Get alerted when CVE-2024-29185 or the next vulnerability affects your stack