What’s Vulnerable › Vulnerabilities
CVE-2024-29198: GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-918
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. It possible to achieve Service Side Request Forgery (SSRF) via the Demo request endpoint if Proxy Base URL has not been set. Upgrading to GeoServer 2.24.4, or 2.25.2, removes the TestWfsPost servlet resolving this issue.
Affected products
- geoserver org.geoserver.extension:gs-db2: from 2.0.0 before 2.24.4; from 2.25.0 before 2.25.2 — fixed in 2.24.4, 2.25.2
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.24.4, 2.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-5gw5-jccf-6hxw
- https://osgeo-org.atlassian.net/browse/GEOS-11390
- https://osgeo-org.atlassian.net/browse/GEOS-11794
Get alerted when CVE-2024-29198 or the next vulnerability affects your stack