What’s Vulnerable › Vulnerabilities
CVE-2024-29201: JumpServer's insecure Ansible playbook validation leads to RCE in Celery
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-94
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Attackers can bypass the input validation mechanism in JumpServer's Ansible to execute arbitrary code within the Celery container. Since the Celery container runs with root privileges and has database access, attackers could steal sensitive information from all hosts or manipulate the database. This vulnerability is fixed in v3.10.7.
Affected products
- jumpserver: from 3.0.0 before 3.10.7 — fixed in 3.10.7
How to fix
Upgrade to a fixed version: jumpserver 3.10.7. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-pjpp-cm9x-6rwj
- https://www.sonarsource.com/blog/diving-into-jumpserver-attackers-gateway-to-internal-networks-2-2
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-pjpp-cm9x-6rwj
Get alerted when CVE-2024-29201 or the next vulnerability affects your stack