What’s Vulnerable › Vulnerabilities
CVE-2024-2921
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-26 · updated 2026-06-17
- Weakness: CWE-306
Description
Improper access control in PAM vault permissions in Devolutions Server 2024.1.10.0 and earlier allows an authenticated user with access to the PAM to access unauthorized PAM entries via a specific set of permissions.
Affected products
- Devolutions Server: before 2024.1.8.0 — fixed in 2024.1.8.0
How to fix
Upgrade to a fixed version: Devolutions Server 2024.1.8.0. Check the vendor advisory for mitigations.
References
- https://devolutions.net/security/advisories/DEVO-2024-0005
- https://devolutions.net/security/advisories/DEVO-2024-0005
Get alerted when CVE-2024-2921 or the next vulnerability affects your stack