What’s Vulnerable › Vulnerabilities
CVE-2024-29220
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Ninja Forms prior to 3.8.1 contains a cross-site scripting vulnerability in custom fields for labels. If this vulnerability is exploited, an arbitrary script may be executed on the web browser of the user who is accessing to the website using the product.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.8.1 — fixed in 3.8.1
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.8.1. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN50361500/
- https://ninjaforms.com/
- https://wordpress.org/plugins/ninja-forms/
- https://jvn.jp/en/jp/JVN50361500/
- https://ninjaforms.com/
- https://wordpress.org/plugins/ninja-forms/
Get alerted when CVE-2024-29220 or the next vulnerability affects your stack