What’s Vulnerable › Vulnerabilities
CVE-2024-29232
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper neutralization of special elements used in an SQL command ('SQL Injection') vulnerability in Alert.Enum webapi component in Synology Surveillance Station before 9.2.0-11289 and 9.2.0-9289 allows remote authenticated users to read database containing non-sensitive information and conduct limited denial-of-service attacks via unspecified vectors.
Affected products
- Synology Surveillance Station: before 9.2.0-9289; before 9.2.0-11289 — fixed in 9.2.0-11289, 9.2.0-9289
How to fix
Upgrade to a fixed version: Synology Surveillance Station 9.2.0-11289, 9.2.0-9289. Check the vendor advisory for mitigations.
References
- https://www.synology.com/en-global/security/advisory/Synology_SA_24_04
- https://www.synology.com/en-global/security/advisory/Synology_SA_24_04
Get alerted when CVE-2024-29232 or the next vulnerability affects your stack