What’s Vulnerable › Vulnerabilities
CVE-2024-29271
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Reflected Cross-Site Scripting (XSS) vulnerability in VvvebJs before version 1.7.7, allows remote attackers to execute arbitrary code and obtain sensitive information via the action parameter in save.php.
Affected products
- givanz Vvvebjs: before 1.7.7 — fixed in 1.7.7
How to fix
Upgrade to a fixed version: givanz Vvvebjs 1.7.7. Check the vendor advisory for mitigations.
References
- https://github.com/givanz/VvvebJs/commit/c0c0545b44b23acc288ef907fb498ce15b9b576e
- https://github.com/givanz/VvvebJs/issues/342
- https://github.com/givanz/VvvebJs/commit/c0c0545b44b23acc288ef907fb498ce15b9b576e
- https://github.com/givanz/VvvebJs/issues/342
Get alerted when CVE-2024-29271 or the next vulnerability affects your stack