What’s Vulnerable › Vulnerabilities
CVE-2024-29489
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-476
Description
Jerryscript 2.4.0 has SEGV at ./jerry-core/ecma/base/ecma-helpers.c:238:58 in ecma_get_object_type.
Affected products
- JerryScript: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: JerryScript 3.0.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/gandalf4a/9826a897ae1e3c8d1c7e71a1ec71d415
- https://github.com/jerryscript-project/jerryscript/commit/cefd391772529c8a9531d7b3c244d78d38be47c6
- https://github.com/jerryscript-project/jerryscript/issues/5101
- https://github.com/jerryscript-project/jerryscript/pull/5129
- https://gist.github.com/gandalf4a/9826a897ae1e3c8d1c7e71a1ec71d415
- https://github.com/jerryscript-project/jerryscript/commit/cefd391772529c8a9531d7b3c244d78d38be47c6
- https://github.com/jerryscript-project/jerryscript/issues/5101
- https://github.com/jerryscript-project/jerryscript/pull/5129
Get alerted when CVE-2024-29489 or the next vulnerability affects your stack