What’s Vulnerable › Vulnerabilities
CVE-2024-2950: BoldGrid Easy SEO – Simple and Effective SEO <= 1.6.14 - Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-06 · updated 2026-06-17
- Weakness: CWE-200
Description
The BoldGrid Easy SEO – Simple and Effective SEO plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.6.14 via meta information (og:description) This makes it possible for unauthenticated attackers to view the first 130 characters of a password protected post which can contain sensitive information.
Affected products
- BoldGrid Easy SEO – Simple and Effective SEO: before 1.6.15 — fixed in 1.6.15
How to fix
Upgrade to a fixed version: BoldGrid Easy SEO – Simple and Effective SEO 1.6.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/boldgrid-easy-seo/tags/1.6.15/includes/class-boldgrid-seo-admin.php?rev=3064911
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d502e617-a59f-4385-b050-3702a1b1ed7e?source=cve
- https://plugins.trac.wordpress.org/browser/boldgrid-easy-seo/tags/1.6.15/includes/class-boldgrid-seo-admin.php?rev=3064911
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d502e617-a59f-4385-b050-3702a1b1ed7e?source=cve
Get alerted when CVE-2024-2950 or the next vulnerability affects your stack