What’s Vulnerable › Vulnerabilities
CVE-2024-29507
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-120
Description
Artifex Ghostscript before 10.03.0 sometimes has a stack-based buffer overflow via the CIDFSubstPath and CIDFSubstFont parameters.
Affected products
- Artifex Ghostscript: before 10.03.0 — fixed in 10.03.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.03.0. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=707510
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=7745dbe24514
- https://www.openwall.com/lists/oss-security/2024/07/03/7
- https://bugs.ghostscript.com/show_bug.cgi?id=707510
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=7745dbe24514
- https://www.openwall.com/lists/oss-security/2024/07/03/7
Get alerted when CVE-2024-29507 or the next vulnerability affects your stack